Postup Instalace HA na SSD s Raspberry Pi4 4GB

Raspberry Pi 4 Model B (1 GB, 2 GB, 4 GB and 8 GB model) 64-bit
Odpovědět
kiklhorn
Moderátor
Moderátor
Příspěvky: 62
Registrován: 03. červenec 2021, 18:35
Dal poděkování: 9 poděkování
Dostal poděkování: 14 poděkování

Re: Postup Instalace HA na SSD s Raspberry Pi4 4GB

Příspěvek od kiklhorn »

On tam ten čip tak nějak sám sedí - kolem je jen flash s vid/pid pro usb definici a nějaká bižuterie.
Ale Pete má pravdu - nebude z toho kompaktní zařízení a pokud to nemusí být kompaktní tak převodník usb/msata je za drobných 5-10 USD.
Dlouholetý ajťák co pamatuje BBS a OS/2 Warp a je mu jedno o jaký systém nebo síťařinu běží, bývalý a znovu začínající elektronik, 50/1978 §8, zvědavec s pocitem že se svět zbláznil a začíná připomínat film "Absurdistán".

lubost
Začínající autor
Začínající autor
Příspěvky: 41
Registrován: 03. duben 2021, 15:19
Dal poděkování: 2 poděkování
Dostal poděkování: 1 poděkování

Re: Postup Instalace HA na SSD s Raspberry Pi4 4GB

Příspěvek od lubost »

Zdravim,

preinstaloval som fungovanie na SSD disk podla navodu na prvej stranke, vsetko prebehlo hladko (aj ked ta prva cast bezala u mna skoro hodinu, asi slabsia SD karta).
Po obnove HA zo zalohy mi vsak nefunguju integracie cez ZigBee... nieco malo sa rozbehlo, ale vacsina nefunguje.
Zapojenie ConBee II som mal aj predtym cez predlzovaci USB kabel, pretoze v USB3 mam este Z-Wave usb kluc. SSD disk som pripojil na druhy USB3 port tiez cez predlzovaci USB kabel.

Skusam davat obnovu topologiu, prekonfigurovat konkretne zariadenie, nic nepomaha. Nerad by som rozoberal krabice, aby som nanovo spustal parovanie napajanych zariadeni :-(

V ramci povodnej topologie to vyzeralo, ze z ConBee to islo na najvzdialenejsiu zasuvku a z nej potom boli napajane ostatne zariadenia. Dal som ju odobrat, ci nahodou sa nepripoja tie zariadenie inou cestou... a teraz uz sa neda vobec pripojit.
V logu som nasiel aj nieco take:
Logger: zigpy_deconz.zigbee.application
Source: /usr/local/lib/python3.9/site-packages/zigpy_deconz/zigbee/application.py:55
First occurred: 8:25:01 (65 occurrences)
Last logged: 12:12:18

alebo:
Logger: zigpy_deconz.zigbee.application
Source: /usr/local/lib/python3.9/site-packages/zigpy_deconz/zigbee/application.py:331
First occurred: 10:47:07 (1 occurrences)
Last logged: 10:47:07

Unexpected transmit confirm for request id 29, Status: TXStatus.MAC_CHANNEL_ACCESS_FAILURE
Nema niekto nieco odskusane? niekde som cital, ze odstranit subor zigbee.db, ale to by som asi musel nanovo vsetko pridavat...,

version: core-2021.7.4
python_version: 3.9.5
os_version: 5.10.17-v8
host_os: Home Assistant OS 6.2
installed_addons: Z-Wave JS to MQTT (0.22.1), File editor (5.2.0), Samba share (9.3.1), Terminal & SSH (9.1.0), Z-Wave JS (0.1.29), Duck DNS (1.13.0), eWeLink Smart Home (1.0.0)

(skusal som uz aj core 2021.8.1, ale vypadlo mi tam toho potom este viac, hlavne snimace teploty cez bluetooth, tak som to vratil zatial spat...)

Sorry za dlhy prispevok.

Lubo

PepYk_
Aktivní autor
Aktivní autor
Příspěvky: 55
Registrován: 03. květen 2021, 12:29
Dostal poděkování: 7 poděkování

Re: Postup Instalace HA na SSD s Raspberry Pi4 4GB

Příspěvek od PepYk_ »

lubost píše: 07. srpen 2021, 12:28 Po obnove HA zo zalohy mi vsak nefunguju integracie cez ZigBee... nieco malo sa rozbehlo, ale vacsina nefunguje.
Zapojenie ConBee II som mal aj predtym cez predlzovaci USB kabel, pretoze v USB3 mam este Z-Wave usb kluc. SSD disk som pripojil na druhy USB3 port tiez cez predlzovaci USB kabel.
Obávám se, že nejrychlejší a nejjednodušší způsob bude vše napárovat do zigbee sítě znovu ;)

lubost
Začínající autor
Začínající autor
Příspěvky: 41
Registrován: 03. duben 2021, 15:19
Dal poděkování: 2 poděkování
Dostal poděkování: 1 poděkování

Re: Postup Instalace HA na SSD s Raspberry Pi4 4GB

Příspěvek od lubost »

PepYk_ píše: 07. srpen 2021, 20:50 Obávám se, že nejrychlejší a nejjednodušší způsob bude vše napárovat do zigbee sítě znovu ;)
A najlepsi postup? najprv odobrat vsetky zariadenia a potom odinstalovat ZHA? a znovu nainstalovat ZHA a pridavat zariadenia?
lebo aj ked chcem teraz pridat uplne nove zariadenie, tak sa mi neda pridat... :-(

Lebo ma napadlo skusit iba odinstalovat ZHA a znovu nainstalovat... ak nepomoze, tak potom rovno odmazat subor zigbee.db?

Lubo

lubost
Začínající autor
Začínající autor
Příspěvky: 41
Registrován: 03. duben 2021, 15:19
Dal poděkování: 2 poděkování
Dostal poděkování: 1 poděkování

Re: Postup Instalace HA na SSD s Raspberry Pi4 4GB

Příspěvek od lubost »

Zatial si odpovedam sam... odinstaloval som ZHA, vymazal povodny subor DB, aktualizoval na najnovsie verzie... ale nedari sa mi vobec nic pripojit... ani uplne nove zariadenie, ani nejake povodne... ci uz na baterku alebo zapojene do siete (napajane), cize malo by fungovat ako dalsi siritel signalu... nova verzia 6.2c, na ktoru som presiel instalaciou na SSD teda absolutne mi tuto integraciu zrusila...
Zatial som totalne zufaly, ze po takomto vypadku mam odstavenu podstatnu cast domacnosti, co som mal uz zapojene... :-(

Lubo

PepYk_
Aktivní autor
Aktivní autor
Příspěvky: 55
Registrován: 03. květen 2021, 12:29
Dostal poděkování: 7 poděkování

Re: Postup Instalace HA na SSD s Raspberry Pi4 4GB

Příspěvek od PepYk_ »

Zkus smazat celou databázi HA: config\home-assistant_v2.db
Zkus udělat celý postup instalace ConBee od začátku: https://blog.vyoralek.cz/iot/vlastni-zi ... -a-deconz/

lubost
Začínající autor
Začínající autor
Příspěvky: 41
Registrován: 03. duben 2021, 15:19
Dal poděkování: 2 poděkování
Dostal poděkování: 1 poděkování

Re: Postup Instalace HA na SSD s Raspberry Pi4 4GB

Příspěvek od lubost »

nic nepomaha... tak ako som "lavou zadnou" pridaval dalsie a dalsie prvky Aqara senzorov ci spinacov, aktualne nedokazem ani cez ZHA ani DeConz absolutne nic pridat, nastavit... zariadenie je spravne rozpoznane, prestudoval som dalsie videa, nainstaluje a spusti sa aj rozhranie pre Phoscon, ale ziadne zariadenie sa mi nasledne nepodari pridat... obnovoval som zalohy po prechode, na ZHA integraciu a skusal tam odznova, nic...
vymenil som predlzovaci USB kabel, pripojil zariadenie priamo do USB portu, nula bodov... ked aj aktualizujem na Core 8.4, pridavaju sa problemy aj so Z-Way zariadeniami... prechod na SSD teda zatial sklamanim, lebo totalne to rozhadzalo u mna Zigbee (kde uz toho bolo pripojene slusne mnozstvo senzorov, spinacov Aqara...).
U mna to vyzera na problem samotnej verzie 6.*... kym bola 5.*, tak to ficalo...
Neviem, co by sa stalo, ak by som obnovil zalohu pred prechodom na SSD a vlozil opat SD kartu... ci by to zabralo, alebo uplne to uz cele rozhasim (kedze pred prechodom na SSD sa skoro hodinu nieco instalovalo za pomoci inej SD karty... len kde sa to ulozilo a co to prepisalo)

Lubo

lubost
Začínající autor
Začínající autor
Příspěvky: 41
Registrován: 03. duben 2021, 15:19
Dal poděkování: 2 poděkování
Dostal poděkování: 1 poděkování

Re: Postup Instalace HA na SSD s Raspberry Pi4 4GB

Příspěvek od lubost »

rano som vratil povodnu SD kartu, po spusteni HA vacsina Aqara zariadeni hned fungovala, niektore som este musel nanovo pridat, ale bez problemov sa pripojili ako ZigBee zariadenia cez povodny ConBee II. Taktiez som pridal novo zakupene vypinace a tiez bez problemov boli ihned rozpoznane a funkcne...
Pouzivam povodnu integraciu ZHA, aktualne system core-2021.7.4, OS Home Assistant OS 6.2.
V podstate to iste bolo aj s tym SSD diskom, aj tam to ConBee II bolo rozpoznane, viditelne pre pracu, ale nebolo mzne pridat ziadne zariadenie a ani povodne nefungovali... nechapem...

Zatial pobezim na SD karte, kym niekde nieco nenajdem...

Lubo

PepYk_
Aktivní autor
Aktivní autor
Příspěvky: 55
Registrován: 03. květen 2021, 12:29
Dostal poděkování: 7 poděkování

Re: Postup Instalace HA na SSD s Raspberry Pi4 4GB

Příspěvek od PepYk_ »

lubost píše: 09. srpen 2021, 08:18 rano som vratil povodnu SD kartu, po spusteni HA vacsina Aqara zariadeni hned fungovala, niektore som este musel nanovo pridat, ale bez problemov sa pripojili ako ZigBee zariadenia cez povodny ConBee II. Taktiez som pridal novo zakupene vypinace a tiez bez problemov boli ihned rozpoznane a funkcne...
Pouzivam povodnu integraciu ZHA, aktualne system core-2021.7.4, OS Home Assistant OS 6.2.
V podstate to iste bolo aj s tym SSD diskom, aj tam to ConBee II bolo rozpoznane, viditelne pre pracu, ale nebolo mzne pridat ziadne zariadenie a ani povodne nefungovali... nechapem...
Tak zkus celý HA postavit celý znovu od začátku na SSD disk bez obnovy dat ze zálohy z toho původního HA. Udělej na SSD nový flash OS HA, připoj ho do USB a nic jiného do USB už nepřipojuj. Až rozeběhneš systém z SSD, potom teprve přidej ConBee a k němu Addon. Zkus napárovat nějaké zařízení. Když to nepůjde, zkus jiný USB port. A nakonec, když bude vše funkční přidej teprve Zwave...
A ještě bych zvážil, jestli zůstat u ConBee, přece jen jeho kompatibilita je docela mizerná oproti zegbee2mqtt ;)

lubost
Začínající autor
Začínající autor
Příspěvky: 41
Registrován: 03. duben 2021, 15:19
Dal poděkování: 2 poděkování
Dostal poděkování: 1 poděkování

Re: Postup Instalace HA na SSD s Raspberry Pi4 4GB

Příspěvek od lubost »

PepYk_ píše: 09. srpen 2021, 09:38
Tak zkus celý HA postavit celý znovu od začátku na SSD disk bez obnovy dat ze zálohy z toho původního HA....
...A ještě bych zvážil, jestli zůstat u ConBee, přece jen jeho kompatibilita je docela mizerná oproti zegbee2mqtt ;)
no velmi nerad by som zacinal "uplne nanovo"... uz tam mam celkom dobry pocet zariadeni, vytvorenych automatizacii... ale ak nebude inej cesty... hm...

ohladne toho zigbee2mqtt... ktore konkretne? lebo ked dam hladat, tak dostanem velmi vela vysledkov a za desatinu ceny ConBee, tak ma to az "ľaká", ze by toto malo byt podstatne lepsie... :-D
A ak to treba este dalej nejako programovat, hm, neviem... Sice aj ten HA som objavil nejaky stvrtrok dozadu a teraz uz v tom mam kadeco... ale zase ma to aj vylakalo (ten vypadok), ze som vrazil uz celkom slusne peniaze za rozne veci a ked to takto bude vypadavat, tak budem oskalpovany...

Lubo

Odpovědět